MK2 and Mssiah cartridge

Caution: Non registered users only see threads and messages in the currently selected language, which is determined by their browser Please create an account and log in to see all content by default. This is a limitation of the forum software.
Don't Panic. Please wash hands.
  • Hi all,

    I’m trying to use the Mssiah cartridge but after power on the usual basic prompt appears. On a classic machine, no problem.

    Maybe it’s due to a particular protection boot routine against dump, but I wonder if it could be fixed just to use my original cartridge.

    Just for information, same happens on Ultimate64, that’s why I guess it’s regarding a non-standard bootchain.

  • I have actually tested mssiah with the MK2 and it worked for me... *shrug*.

    you can try the workaround for MK1... press and hold reset, then power on, release reset. (might be easier with a reset button added to the userport, for example)

    really surprising behaviour though, because as said, i have tested it. another shoot in the dark: are you using the original ROMs? if not, try doing that.

  • Nothing to do.

    I tried the following:

    - With 1xArmSID

    - With 2xArmSID: KO

    - With 1xoriginal SID: KO

    - With 2xoriginal SIDS: KO

    - Reverted to the original FW 20171114: KO

    - Reupdated to latest 20180227 FW: KO

    As I said before, on a standard machine the MSSIAH cartridge starts.