V2 Case screw

Caution: Non registered users only see threads and messages in the currently selected language, which is determined by their browser. Please create an account and log in to see all content by default. This is a limitation of the forum software.

Also users that are not logged in can not create new threads. This is a, unfortunately needed, counter measure against spam. Please create an account and log in to start new threads.

Don't Panic. Please wash hands.
  • Any one else have problems opening the case to install a battery for the RTC? :/

    Screw will not budge and was half stripped to start. So think it was powered screwed in. It is also a specialized screw and not simple common US type.

    As have been into computers so 80's so I have many size special tools none of which fit. Nor could I loosen it via wrench on a screwdriver that at least fit. Now have tried to chisel it out and still has not budged. I am currently slowly cutting case away from head. Once open I will use pliers to get the screw out and replace with oversize head screw.

  • Found a few on Amazon - bit pricey at $8 for the cheaper PZ1 screwdriver, for perhaps a one time use. Still I want the RTC powered :-) Did see a set for the drill so may want invest in that.

  • The TC64 v2 I received this week came with a Torx screw, T8 possibly T9. Thankfully it isn't the Tamper-Resistant Security Torx with a post in the middle that prevents standard Torx drivers. :)

    I do own a PZ1 driver, as mentioned in the manual, but it is incompatible with this variant of the Chameleon. I also have Torx T4-T7 and T10, but not T8 or T9, so I'm also considering replacing the screw.

  • Weirdly, I opened mine up before reading that it was special. Oops. But it worked just fine with a regular torx (can't recall which size) (or was it a Philips, I can't recall) and it closed back up with no issues.

  • The last reply was more than 365 days ago, this thread is most likely obsolete. It is recommended to create a new thread instead.