Lyra3 now rarely works

Caution: Non registered users only see threads and messages in the currently selected language, which is determined by their browser Please create an account and log in to see all content by default. This is a limitation of the forum software.
Don't Panic. Please wash hands.
  • For the past week or so my Lyra3 (A1200 version) is completely useless.

    I turn the system on, the keyboard LEDs flash, go dark, then the keyboard is dead. Only once every 40-50 cold boots does it work.

    I can unplug then plug in the keyboard and the LEDs flash again but still dead.

    Tried removing Lyra3 and cleaning the contacts, tried 4 different PS2 keyboards, no change in behavior. Tried removing power sucking accessories, no change even on completely bare system.

    System is 1D4 with FastATA mk5, BPPC. don't think that matters.

    Annoying because I only bought this thing two months ago.


    Something I found tonight is that it comes working if the computer has been on for an hour. This even persists through a cold reboot - A few seconds into the boot the lights flash and then the numlock stays lit and I can type again.

    This isn't ideal at all, I don't like that my computer has a 1 hour warm up time. It's not a valve radio

  • This may be a simple power supply issue - you did write that you've removed "power sucking accessories", but that of course does not make a high-ripple PSU work, as it will still output high ripple, causing the MCU on Lyra to frequently reset (frequently as in "several times per second").

    Your description even seems to confirm this, as electrolytic capacitors tend to work slightly better if they warm up. You may get your system to work much more reliable if you exchange the DC side caps of your power supply.

  • It's a Corsair SF450 less than 6 months old.

    I'm sorry but I simply cannot accept your excuse, even if it is technically true that the Lyra cannot handle the amount of ripple.

    Every other part of the computer, the motherboard, the drives, the fastata, the BPPC, the Bvision, your rapidroad, the ethernet card etc all work immediately and perfectly on this "high ripple". (Perhaps you know that Bvision in particular is famed for power related instability.) So does everything in a normal PC, if I use this PSU to power one.

    Now if every other computer part on god's polluted earth works correctly with this PSU, the conclusion is that the PSU is not "high ripple". It is normal ripple, totally within expected behavior, and Lyra 3 demands usually low ripple.

    But I will say that your answer is something I should've expected, you're famous for blaming every problem with your products onto other people's products, commodore, the user etc. Saint Jens can do no wrong.

  • It's a Corsair SF450 less than 6 months old.

    That PSU has 100W power on the 5V rail, but over 400W power on the 12V rail. That means that it's main regulation rail is the 12V rail, and the 5V rail is only co-regulated. In other words: Not suitable for the Amiga. Please look for a PSU that has higher power on the 5V rail than on any other voltage, or one that uses modern DC-DC technology where each rail has it's own regulation.

    I'm sorry but I simply cannot accept your excuse

    I'm sorry, but it's not an excuse, it's a fact. If you believe that Lyra3 is at fault, please send it back to your reseller or to us if you're a direct customer.

    Now if every other computer part on god's polluted earth works correctly with this PSU, the conclusion is that the PSU is not "high ripple".

    Sorry, but ripple can only be measured, for example with an oscilloscope.

    I can of course be wrong, and the fault is somewhere else - maybe a solder problem between the keyboard MCU and the A1200 main board, which is another well-known problem. Your tone is definitely off - if you want people to help you, it may be a good idea to apply basic principles of human interaction. First warning.

  • The last reply was more than 365 days ago, this thread is most likely obsolete. It is recommended to create a new thread instead.