ECSv2 Latest firmware / settings tool graphic corruption and instability

Caution: Non registered users only see threads and messages in the currently selected language, which is determined by their browser Please create an account and log in to see all content by default. This is a limitation of the forum software.
Don't Panic. Please wash hands.
  • Just saw the post for the latest update for 2.3 20190516 and updated as I had with previous versions.

    Tried the settings tool to make adjustments and it now displays the adjustment window with corrupted graphics. If I try to adjust the settings more than twice the Amiga will crash while displaying a single gray color on screen , occasionally with audio glitching.

    Also, testing NTSC and PAL HiRes modes in Screenmode prefs from Workbench produces a bad sync signal; CRT on Amiga RGB is unable to sync and I get a wobbly rolling screen with huge amount of distortion and on my Dell LCD connected to the VGA port refuses to display anything. Everything worked fine in the last firmware. However, PPaint 7.3c is able to output HiRes/SHiRes normal and laced modes without issue to the RGB port and VGA just fine. Played PowerGlove Unleashed for 30 mins to see if there were any problems and it ran fine. Overscan settings for both NTSC and PAL were able to display perfectly.


    I attempted several reflashes and cleared the saved settings.


    Is there a link to the previous .lha as I seem unable to find the backup I thought I saved. I am planning to roll back.

  • Update:


    The VGA port does display the HiRes test modes in Screenmode prefs.

    Attempting to use the settings tool to adjust the settings in anything other than LowRes causes the Amiga to lock up #8000000A.

    I was able to find the 20190903 file and flash down with the rescue disk and it is giving the same behavior now also... very strange.

  • If possible please upload your configuration file IndivisionECSv2.conf from ENV:/ENVARC:.

    This is only a wild guess, as there is not much interaction with the outside world except for the configuration that could cause such horrid corruption. Does the config tool work when started booting without startup-sequence?

  • Thanks for the reply Timm.


    I will have a chance to test starting the configuration tool with no startup-sequence tomorrow evening. However, after my last post here I did try deleting the config from ENVARC: before I did a re-flash from the emergency recover disks to try to start over completely clean. It is likely that the same configuration file is still on my backup of my system drive but I will have to check.

    I will update tomorrow.

  • Okay some follow ups...


    1. Booting with no startup-sequence allows the config tool to work without issue. I should have been smart enough to try this but it just didn't occur to me. (I've been getting back to my Amiga to try to decompress from work...) Anyhow, this positive result led me to disabling individual tools like fblit, blazewcp, etc one at a time. Finally disabling MCP from startup allowed the config tool to work correctly from a normal bootup. I then disabled and re-enabled each of the parts of MCP I had been using for quite a while now and it turned out that the NewGadTools patch was conflicting. When it is off the config tool works fine from a normal startup. One problem solved. Not sure when the setting was turned on and left on, but it is possible when I was just trying different options in MCP I never noticed an issue because once I got the Indivision configured I basically left it. (I also use my CRT most of the time because of the as of yet unresolved ghosting issues on the ECSv2.)


    2. Next, I re-tested HiRes / HiRes Laced NTSC or PAL modes. From Screenmode prefs it still yielded a screen that rolls and is distorted. However, Oversan prefs works fine as does setting the screen mode to HiRes Laced in PPaint. Putting my original OCS Denise in allowed Screenmode prefs to work normally. I went back to the Indivision and started again with disabled Startup-sequence. I had not tested Screenmode prefs like this earlier. It worked fine; displayed a perfect test picture. I then went quickly through the startup-sequence again and decided to comment out the bblank border blanking tool. Reboot and test screenmode prefs and HiRes and laced modes test perfectly. So it seems this is maybe having something to do between the ECSv2 and bblank or maybe my combination of hardware with bblank.... I dunno.


    3. My backed up configuration file is attached though now I am not sure it is of relevance.


    4. System Specs


    Amiga 500 rev 6a w/A501 for realtime clock.

    Vampire 500 v2+

    OS 3.1.4 with 3.1.4 ROM on Vampire.

    ACE2 Chipram extender

    Gotek floppy emulator


    I certainly hope any weirdness isn't due to my Agnus... Hasn't been that long since I got the ACE2 and I have been quite happy with it and how easy it was to install.

  • You did find some important things, such as MCP, which is about as depreciated as most of the OS patches by a well-known French guy. I believe that your Agnus is OK, but your system is over-patched.


    With Vampire in the system, you have introduced a major incompatibilty, such as additional registers in the chip register area that are normally unused, and of course CPU incompatibilities. We can of course look at any interferences with BBlank, but since we don't have any Vampire here for testing, we can only confirm proper function with a real 68k CPU.

  • Sorry for the delay in getting back on... parent life.

    I will likely move away from using MCP at all and look into other options for border blanking and see if the problems persist. I am glad the Agnus is okay and that the Indivision is working as well as it was when it was installed with bblank and NewGadTools patch disabled.

    Thanks for taking the time to consider this and respond.

  • I actually don't use MCP for border blank. I have had a tool in C: called bblank for a very long time that I have always used. I didn't even discover MCPs option for border blanking until this problem and I could not get it to do anything at all when I was testing so it remains disabled. I use MCP primarily for GUI patches like moving / changing Workbench's screenbar text, adding a clock, etc.

    I will try the BorderBlank tool you linked to and see if there is an improvement.

  • I figured it out. I had disabled everything when I remembered P96.


    When I got the Indivision my A500 suddenly had an ECS Denise which would allow 31khz video. I used this with P96 to allow AmigaAmp to play mp3s with much better quality. I didn't notice my CRT screen rolling because BBlank was kicking in at boot the same time P96 was giving me a display from the Vampire.


    So with Env:Picasso96/AmigaVideo set to 31khz and my original BBlank loaded I get this in Screenmode hires test:


    VGA from Indivision -> Working

    CRT from Amiga -> Rolling distorted screen.


    P96 AmigaVideo set to 15khz and BBlank loaded


    VGA -> Working

    CRT -> Working


    So MCPs NewGadTools corrupts the UI of the config tool.


    P96 31khz AmigaVideo and border blanking (either the one I have been using or the one linked by Jens) makes the Screenmodes test screen roll and distort on the Amiga video port.


    I don't often play mp3s on my Amiga so disabling 31khz is no big deal really.


    I am guessing PPaint and Overscan prefs work in Hires no matter what because they open full new screens (forcing the chipset back to 15khz) and don't use the default one that is created at boot that P96 is putting into 31khz.

  • The last reply was more than 365 days ago, this thread is most likely obsolete. It is recommended to create a new thread instead.