My Rapid Road dead..think i shorted something ?

Caution: Non registered users only see threads and messages in the currently selected language, which is determined by their browser. Please create an account and log in to see all content by default. This is a limitation of the forum software.

Also users that are not logged in can not create new threads. This is a, unfortunately needed, counter measure against spam. Please create an account and log in to start new threads.

Don't Panic. Please wash hands.
  • I normally have a short USB extension cord from rear plate of my A4000 to the front so i don't have to always clear stuff off my desk to see behind myA4000 when swapping USB stuff in and out. Tonight for some reason I had taken out the USB extension and was too lazy to move stuff to plug in a USB stick so I clumsily tried inserting it by feel and could here the metal to metal noise while scraping away until finally found the slot it connected BUT this time no familiar Poseidon pop up screen showed up??? tried turning off computer, rebooting still nothing....took off the case and dammit the light was off on my Rapid Road so i fear I've burned something out :-(

    I feel really stupid for being so lazy & I hope it can be fixed as I use it quite often;(

  • Confirmed - that's the only address we have. Please include a short letter that says what to do with the unit. My employees can't possibly dig through the forum and try to identify error descriptions.

    If you ship from outside Europe, please declare that actual value (not higher, not lower), and also include a copy of the original invoice, showing that the unit is returned for service. Everything should be accessible from the outside, so customs can access the paperwork without having to open the parcel.

  • The last reply was more than 365 days ago, this thread is most likely obsolete. It is recommended to create a new thread instead.