Updating the Firmware on a ACA500+

Caution: Non registered users only see threads and messages in the currently selected language, which is determined by their browser. Please create an account and log in to see all content by default. This is a limitation of the forum software.


Also users that are not logged in can not create new threads. This is a, unfortunately needed, counter measure against spam. Please create an account and log in to start new threads.

Don't Panic. Please wash hands.
  • Hi just received my ACA500+ Current version of Menu is ..146 and my version is .126

    Q1 Does it matter if I have actually Loaded 3.1 to the CF Card via F7 just need to do it again I suppose ?

    I am reading the info on the site and it talks about updating the installer also Quote

    "The newest version will break the old OS installer, so it's strongly recommended to also update the OS installer, to at least version 1.5 (see below)."

    I have tried to put the installer on the same Aux CF Card, but it say its the same file.

    Q2. So this Menu update does both ?

    Q3 Writing the ADF file to a Floppy disk is that on the PC or the Amiga (for backup) as the file does not show up in workbench

    Q4 Any other updates that I need to do ?


    Thanks

  • 1. No, you don't need to install 3.1 again.

    If you update the Menu to 0.146, then please also update the Installer to v1.5.

    You can launch the installer without actually starting to install, to check the version.

    2. Not that I'm aware of

    3. On an Amiga

    4. You can of course also update the network installer, if you're interested in adding an X-Surf-500.


    If you plan to run OS 3.2, or have an ACA1234, or if you want to install to a 32GB compact flash without accelerator, then the update is for you. If you might want to install an X-Surf-500 some day and you are running OS 3.2, then the update is for you.

    There are also smaller unnamed bug fixes and corrections, so the general recommendation is to update.


    Regarding 3.1 installation: If you install OS 3.1 with our new installer, it will also be "aware" of OS 3.2, which wasn't the case before.

    Our general recommendation is to install OS 3.1, and to install OS 3.2 over the existing system, if you so wish.

  • Hi

    I cannot see the version of the installer when I hit F7, F1 and than F1 ( going right into starting to instal 3.1 again)

    How do you actually update the installer.

    I want to install a 32GB CF card also so I do need to install the updates

    Not planning on running OS 3.2 at this stage


    Thanks

  • Ah ok, if you don't see it when launching the installer, then it hasn't been updated yet.

    Because the old installer didn't show its version - the new version does, although very shortly, after writing "Starting ACA500plus installer ..." (Press L-AMIGA m to get back to the shell window if it vanished too quickly.)

  • Could not see any mention of Version on the shell. (Photo attached)

    Q1 How do I update the installer ?

    Q2 Do I just put one of these files on the Aux CF card to update See Photo

    Q3 Do I just put one of these files on the Aux CF card to update the Menu (Media.ACA500+Menu0.146lha. Media.ACA500+Menu0.146zip) See Photo.


    I have tried to put both the Menu file and the Installer file on the Aux card but it states "Do you want to this replace file"

    So I appears I need to do the Menu update and the Installer update separately.

    Q4 Which one should I do first ?


    Thank you

  • Hi Timm

    Updated both the Menu and the Installer, so please ignore my previous post.

    I cannot check the version of the installer as it now seems to go straight through to WB3.1 even after hitting F7 and going through a pretend install process.


    I actually want to do a custom install using a 32gb CF card. I have hear that the FFS can be unstable at times. and the PPS3Aio is a better option.

    Whats your thoughts on this ?

  • The installer won't start installation automatically.

    The screenshot of the installer coming up shows that the installer was not updated, because no version number is shown. It should read something like 1.5, build...

    You said earlier you installed 3.1 successfully, why are you installing it again, because it's not on the target 32GB media yet?

    Please try updating the installer again.

    When the purple start screen comes up, then there's no bootable media or drive. On the ACA500+ the media is expected in the right (boot) slot.


    Edit: Oh, and don't worry: The Installer will use PFS3 when needed, and not use FFS if it's unsuitable for the partition size.


    To update the installer, download http://wiki.icomp.de/w/images/1/14/Aca500%2Binstaller1.5.zip, unarchive, copy UPD500P.ADF to a PC-formatted compact flash card, insert the CF into the AUX slot on the ACA500+, in the ACA500+ menu use F8 to enter the flash updater, press "f" to run the flash updater. The same procedure is required for all updates - so chances are that your other updates didn't go well either! To check the menu version, press the Tab key in the menu's main screen. "ACA500p ROM: v0.146..." is expected here!

  • Another note: I haven't tested with a 32GB CF myself, 16GB is the biggest medium I have, so there is a chance that it doesn't work with >16GB.

    If you should find the installer bailing out prematurely, please remove any CF from the AUX slot, or deselect "1 AUX CF Slot activated" in the ACA500+ installer menu. If that doesn't help, you must try with a smaller medium, or use an accelerator that delivers the required extra memory to deal with such a huge medium. But in any case you need to make sure that both updates of menu (v0.146) and installer (1.5) went successfully.

  • Hi Timm.

    The menu update went successfully before as I checked and it said 0.146

    When I did the updated installer it stated successful and said to reboot

    The reason I was wanting to use the 32gb because the 16gb was from my good camera.

    I have since got a 16gb (Hard to come by) So I will Try that.

    I want to do an F3 install, but it looks like needing to be a 16gb also


    I will try your suggestion again tks re install and card


    Cheers


    John

  • Hi Timm

    Updated the installer again.

    This was the message I got last time and this time (Screen Shot)

    The insert disk screen is when the Aux is off and when its on goes to the shell prompt. (previous Post)

    Anyway tried a 16gb and got it to work after 5 tries. (Strange)

    Just a Question on F9 and F10 Are the Ram configarations correct. As When I go Rest Default the F4 Fast ram goes to max On the expert option.

    I will try to partition a 32gb flash card as thats the only cards I could get at the moment. Apart from the 16 GB I have. tks


    Tks

    John

  • Your expert options suggest these are tuned for maximum compatibility (7M Fast RAM disabled), but you need maximum fast memory for operating big CF partitions. The cloaking device expert options are also for compatibility and not needed here. Launching the system with F1 should be fine.

    Your results suggest that something is shaky, but it's difficult to pinpoint. I may have been overly optimistic with regard to a 32GB card (not tested), but installing a 16GB card should be no problem when there's no AUX card present at the same time.

    I may have to rethink the installation procedure for even bigger cards in the future...

  • Timm,

    Thank you

    In your quote "Your results suggest that something is shaky" do you possibly mean try to use the 32GB card.

    If that is the case I will try to source anoter 16GB card


    Now I have to learn how to download and use WHDLoad and put WHDLoad games on the aux, so I can tranfer to the Work drive


    Thanks you

    John

  • I'd suggest to try the 32GB card and report back if it worked.

    On the other hand, mounting big partitions needs more memory - 32GB is truly gigantic for an Amiga 500 with just a 68000 CPU, you will hardly ever be able to fill it with software.

    Bigger media make more sense with an accelerator card, because the accelerator usually brings a large amount of its own memory, and you would be able to use more software which is also suitable for higher CPUs.

    For WHDLoad purposes, 32GB is crazy much. It's increasingly difficult to find smaller CF cards, and if you find them, they are not proportionally cheaper, so people tend to simply buy the bigger cards.

  • Hi Timm,

    I have partitioned a SanDisk 32GB to 9gb Fat32 (Its a SanDisk Extreme 60m MB/s UDMA).

    The 16gb CF card that is work is Ultra 30MB/s

    I get exactly the same result when using F1 with Aux off.
    Of course I tried the 32gb size to no avail.

    Get the same WB 3.1 screen asking for a disk.

    The F1 on the install is working exactly like the F1 when running the 3.1 that works on the other 16gb CF card and thus no disk loaded on the CF it goes to the WB 3.1 screen.

    It does not even try to unpack the 7 WB disks.

    I tried flashing the Installer again and that was fine, but made no difference.

    As stated earlier I had to have a few goes to get the 16GB to work, but tried 3 or 4 this time no go.

    So :-

    1. If could be the CF card

    2. Could it be the installer ?


    Tks

    John

  • This sounds more like a bad CF card. Note that the hardware separates the two CF card slots on most of the signals (need to check if there's any common signal), and if the AUX card keeps the computer from using the BOOT card, there is something seriously wrong on the hardware side.


    Is *any* CF card working in the AUX card? Can you try to boot the 16G card in the AUX slot to see if the slot itself works? The ACA500plus will automatically mount an Amiga-formatted card in that slot as well, but it won't support hot-plugging it.

  • 1. Yes, could be the card.

    2. Yes, could be the installer, but in combination with a too big card.


    To remove any doubts about what the procedure is supposed to look like, and for reference, this is with a 16GB card:



    Is installation successful with a 16GB card? Did you see all steps?

  • Hi,

    Thank you so much for getting back to me.

    Yes very frustrating indeed.

    The 32gb card that I Partitioned to 9GB works no problem in the Aux slot. I have loaded files from that card to the work partition on to the 16kg Boot Card. "I-Game program" from Trial (Which is the partitioned 32gb card to 9GB) to "Work" Partition which is the 16GB Card with WB 3.1 on it

    "Trial" is the 32gb card partition to 9gb. " Work and WB3.1" is the 16gb Card. (That I just formatted)

    Unfortunately, before I saw your post. I formatted the 16gb CF boot card (Thats was working) just to see if I could get it up and running again.

    Thats the CF 16gb (In the Photo) will no longer let the the installer work (F7) with Aux off and (no card in the Aux anyway). It goes straight to the insert WB 3.1 disk image. So now I have no WB3.1 installed.

    It does not even give a hint of unpacking the disk images. Performs just like the proper boot card does, but of course not disk images.

    Q1 Why does the the Kickstart Rom in "Expert Options" on both screen revert to Kickstart V3.1 r40.63 instead of the default which is mainboard rom. (Photo attached). Should I be changing this back to mainboard rom every time I try to do the install. (I do hit the default settings though)

    I know in my previous post to Timm that If had to have 3 or 4 goes to get the Installer to work.

    I honestly believe that since I updated the Menu and installer that I have had this issue.

    The 16gb disk (Which had WB3.1 on it) and that stupid me just formatted does show up through the Aux slop on the ACA.


    I just do not know now where to got with this.


    Regards

    John


    PS Just read you post from 46mins ago. Yes that exactly what this 16gb card did. I wanted to do a F3 install so I formatted the card and thought that it worked once. (After a few tries I would give that a go). Unfortunately no go and I cannot get the 32gb formated to a 9gb partition to work either. Not sure if I remember it coming up saying 1.5 installer. Perhaps I will download that again and update it again.


    Regards


    John

  • If you say that installation (pressing "F7 - Installer menu" in the main menu and "F1 OS 3.1 Auto Installer") goes straight to the insert WB 3.1 disk screen, and you don't see the install disks unpacking either, then there's something wrong beyond my comprehension. Is that what you want to say?

    The other question: The main menu can be a bit confusing with regard to switched profiles when you enter a special menu (like installation) and return to the main menu. Don't worry about that and don't switch to the mainboard ROM. After the next power-up, the settings saved in the expert menu will be back again.


    Edit: Your screenshot was once again taken in the "Cloaking device Mode Expert Menu"- just to emphasize, this is not needed/helpful with regard to installation.