Buddha IDE CF Card limit on KS 3.1.4 Amiga 2000?

Caution: Non registered users only see threads and messages in the currently selected language, which is determined by their browser. Please create an account and log in to see all content by default. This is a limitation of the forum software.

Also users that are not logged in can not create new threads. This is a, unfortunately needed, counter measure against spam. Please create an account and log in to start new threads.

Don't Panic. Please wash hands.
  • Hi,

    I bought a Buddha IDE 20 anniv. edition and got it today.

    What is the limit of the CF Card? I have a 64 GB and that one was working on a HC530 in the same Amiga 2000. HC530 is removed and now I have a GVP 030.

    The DOM get recognized but the CF card isn't. The installer starts but doesn't show any additional 'drives', only the DOM.

    I have 2 CF Card adapters but both give no result with the Buddha.

    What can I do?

  • I can just run it and then it works?

    What limit size should I consider? Which is the biggest size you could let work with it?

    I will try tommorow and report back here.

    Thanks for the fast reply.

  • I used the arguments from the indivision: flash firmware

    but then the error comes:

    Maxwait must be combined with persist

    but if I add persist on the end, it give me a write protection error, I'm using the ADF on a Gotek.

  • I copied the ADF to a real floppy, same issue, so it's not the protection of the disk the error is referring too.

    How to disable the protect to be able to upgrade the flash?

    Which arguments do I have to use to upgrade the firmware without any errors?

  • flash protection is normally only activated if the flash update has been performed already. Documentation about using *any* command line tool can be shown with the argument "?".

    The commandline for flashing the ROM is

    buddhaflashtool buddharom.bin

    To lift flash protection (if activated), press and hold the left mouse button on power-up. The software will confirm with a short flash of a black/green pattern on screen.

  • Press Y to start.

    Flashing now...

    Write error address $0800

    Error flashing rom

    when using showconfig: CPLD : yes, Flash:no

    So I presume it's not upgraded yet.

    I booted with left mouse button pressed on power-up. Didnt see a black/green screen. During bootup? Which software are you referring too?

  • I have a suspicion that the Zorro timing is corrupted by your accelerator. Can you try to use a plain 68000 with 7MHz to flash the unit?

    To find out the actual flash version, please check for device names: If there's a "buddha_atapi.device" available, then it's still the old ROM, and software flash protection can't be active.

  • I ran the upgrade without the 030 and the upgrade works.

    It also recognizes now my 64 GB CF Card :)

    My CF card didn't boot up so I used the DOM to install WB 3.1 on KS 3.1.4. It doesnt boot after installing it. Booting from disk with install3.1.4 does not work either.

    Also it seems it doesnt format Work. No LED activity, is this normal during format? Why does it take that long? After one hour I powered off.

    I thought installing SCSI was difficult. But this is not really PnP.

    Tried to install with WB but WB format goes well and quick but on Work it seems it hangs.

  • Is it compatible with kickstart 3.1.4? I removed the settings and booted with only install3.1.4 and it doesnt show the workbench to choose the install.

    if I remove the cf card I can see the workbench and install.

    but this way I cant use hdtoolbox to partition the cf card.

    Do I have to use 3.1 kickstart?

  • Please try a different CF card - maybe the card is just incompatible. The LED is controlled by the card, and depending on how you have connected the LED connector, one or the other slot is shown with that LED.

    Also, please note that CF cards must be inserted before the computer is powered up. You cannot how-swap a CF card that is used as IDE replacement.

  • So it is 3.1.4 compatible ? Using 3.1 kickstart will not work better ?

    I used this CF card on a TF HC530.

    I don't have any other CF card.

    How do I know the c.f. card is supported? Like I asked before which size is supported. And this one works on the TF with kickstart 3.1.4.

  • Sandisk is a brand that I trust will work. However, I'd like to point out that you have bought an IDE controller, not a CF controller. There is a huge difference between the two, and if it would be a CF card controller, there would be a CF card slot on the product.

    I do know that there are 3.1.4 users who also have a Buddha in the system, so that's not the cause.

  • The last reply was more than 365 days ago, this thread is most likely obsolete. It is recommended to create a new thread instead.