NTSC Video Issue After C64R MK2 is Powered On For Extended Time

Caution: Non registered users only see threads and messages in the currently selected language, which is determined by their browser. Please create an account and log in to see all content by default. This is a limitation of the forum software.

Also users that are not logged in can not create new threads. This is a, unfortunately needed, counter measure against spam. Please create an account and log in to start new threads.

Don't Panic. Please wash hands.
  • Jens, I finally got the system to glitch again: I am starting to think the VIC is the issue, here. When the system finally glitched, the VIC chip was too hot to touch. Both the PLL chip and the FPGA were no warmer than any other time.

    So honestly, I think this is mostly a case of heat buildup from the location of the VIC under the keyboard. So at this point, rather than blame this on an electrical fault with the Reloaded board, I'm thinking this is an issue caused by an overheating video chip. I don't think there's anything you can be expected to do about an overheating VIC, and I'm not using the system now anyway, since my Ultimate got here. I'll probably just end up selling off the parts so other people can resurrect their failed systems. =)

    Also, your explanation about the power issue with the WiModem has convinced me that the WiModem just isn't compatible, and so I'm going to try to get an RR-Net on my Ultimate instead.

    So at this point, I don't need to pursue this any further. Thank you. :)

  • I, however, am still experiencing this with two different VIC-II chips. I am willing to send everything over (case, C64R with chips, power supply) and even a LCD TV if it will help. Please let me know.

  • We're experiencing severe delays on incoming shipments due to overloaded customs. Yes, I still need a unit for review, but we should wait until the Xmas rush is over, so the guys at customs are a bit easier to talk to. Meanwhile, I can offer to send you a Commodore power supply, so you can check if the issue is different with that (or even disappears).

  • Hi Jens I replied earlier in this thread and am also experiencing the "NTSC Video Issue After C64R MK2 is Powered On For Extended Time" issue.

    I have multiple NTSC chips and the issues presents on all of them.

    I have finally purchased a PAL VIC chip and was able to confirm that issue does not present with the PAL chip installed. I can (and have) run the system for hours with no issues using a PAL VIC chip.

    Regarding Power Supply: I was pretty sure my power supply was solid but just to be sure I purchased a (very expensive) ATOM from Commodore4Ever who guarantees <100 ripple

    Even with thew new power supply, the NTSC VIC chips continue to present issues after an extended period of time.

    Also, I don't *just* get video issues. I get CIA-related issues as well ... keyboard / joystick input, CIA data transfer, cartridge buttons have all presented along with video glitches (again but only with NTSC VIC installed)

    I am not sure if its best to deal with my support issue here in this thread or to start a new one - Please advise.

    Thank you,

    -David Farrell

  • Let's keep it all in this thread, as the issue appears to be all the same: At NTSC frequency, the PLL does not appear to be stable. However, I'd like to do the test with a Commodore 12V PSU with at least one of you before we attempt to modify the external PLL components.

    Does anyone of you have an oscilloscope?

  • Hi Jens thanks for the reply.

    I'm sorry I don't have an O-Scope nor am I very skilled in electronics -- I do some lightweight soldering and tinkering but not much more.

    I am happy to help any way I can tho ... If you'd like me test a firmware update or run some diag tools, etc. I'd be happy to.

    I don't own a full C64 test harness but hope to get one soon.

    Thanks again.


  • Jens,

    I have just sent the information you requested in an email. Sorry for the delay, I've been busy between the holidays and work.

    You recently asked if any of us has an oscilloscope. Unfortunately, I do not.



  • Hi Jens,

    I'm having this issue. It looks to me like it's an overheating problem with the way the Reloaded MkII motherboard is interacting with the NTSC VIC-IIs or something like that. I've tried with multiple power supplies that I believe fit the specs, but not the one you are selling here. All of the chips are NTSC chips and I have tried completely replacing all of the chips with another set from another known working good C-64. It really does seem to be only the VIC-II chip, and not just the 6567R8, because I had even worse results with a 6567R9. I have two 6567R8s and one 6567R9. One of the 6567R8s is from my childhood C-64 breadbin that has worked without any problems since 1984. The only thing that ever needed replacing was the SID chip sometime in the '90s. So I made a video of the problem.

    Basically, the other two VICs I used the Reloaded MKII would recognize them correctly maybe 1 out of 5 times. I connected with the terminal and saw in those cases it would say PAL unknown for the VIC. The 6567R8 from my childhood C64 the MKII never had any problems recognizing.

    However, I ran the system for an hour, just loading games and playing normally and the text started wiggling a little and finally the full screen garbled. I opened it up, put heatsinks on the VIC-II, waited overnight, and the next day ran it for about 4 hours and then it started acting up the same way. It seems to happen faster it I turn on the space heater in my room, but I live in San Francisco, by the ocean, and it's fairly chilly here. I took the video of the glitching yesterday, apparently the temperature was a high 68° F/low of 51° F which is 20° C/10.56° C, so it's not that hot out. I turned on the heater because I was cold.

    And after it glitched like that, I opened it up and touched the heatsinks with my finger and which it was *warm*, it wasn't burning my fingers or anything.

    Here's the video I made:


    For the record, my monitor is a Sony PVM and it has never had problems with any other thing I've thrown at it and I have a Twin Famicom, an NES, a PlayStation 1, a PlayStation 2, an Xbox, a Super NES, a Sega Genesis (Megadrive)/CD/32X, a Sega Saturn, a Nintendo GameCube, an N64, and a NEC PC Engine CoreGrafx. All have been hooked up it to it, via composite, s-video, or RGB with no issues ever. The monitor supports both NTSC and PAL but none of my computers/consoles is PAL, all straight NTSC. And being in USA, everything is 60hz, power 110.

    My C64 Reloaded MkII is hooked up to it via S-video, but I did check and had the same problem in composite.

    And yes, I updated to the latest firmware before doing any of this.

    Oh, one more note: The only flash cart I have to try on it is the SD2IEC, so nothing big and high power like the 1541 Ultimate or anything.

  • For chip recognition to work properly, the input voltage must be really precise. Can you measure the 12V input when unloaded and when loaded (MK2 switched on)?

    The video distortions shown in your video at roughly 3:30 may be two things, either a power problem, or a clocking problem (PLL of the C64RMK2). If the power blinking is happening, can you enter the remote control menu and post the chipset information that was found?

    The wiggling text that you're seeing is definitely not a heat issue of the VIC chip, but an instability of the PLL. I've tried to reproduce that a number of times here, but was not successful. The PLL chips is U23, about "north east" of the big Xilinx chip. Since I can't reproduce the problem here, I'd need someone in the US who has the problem, but who can also do a little SMD soldering. My first attempt would be to change a resistor value in the VCO control section of the PLL. Can you do such a resistor change, or do you have someone near who could do such a change?

  • Hi Jens,

    Should I be worried about voiding my warranty with soldering? My friend is an excellent modder and can definitely help me with taking values and do SMD soldering work, but I did see you post elsewhere about people voiding their warranties by soldering.

    Also, for the VIC-II chips the Mk2 Reloaded has trouble recognizing the term shows this... I will try recreating the glitched out screen and see what the terminal says when that happens.


  • pwsoft would have to look at the measurement values for the VIC chip. Just for completeness, can you record the values again when the chip is recognized properly?

    Warranty would not be affected if you solder on the board as per my instructions - that's why I asked if you have the skills&tools, or know someone who can do the job.

    Before we get into that, please also do the measurement on the 12V input when switched off and then again when the machine is switched on.

  • Okay Jens, sorry for the delay. Here are pics of it unloaded (got straight 12V named unloaded.jpg), under load (11.97V named loaded.jpg), and under load, we took readings from the LED as well (4.953V). So the power looks fine as far as we can see. I did finally get a PAL VIC-II chip (an 8565R2) so I am going to put it through the same tests and I'll see if there are any issues.

  • The last reply was more than 365 days ago, this thread is most likely obsolete. It is recommended to create a new thread instead.