Queries on a couple of things with the TCV2

Caution: Non registered users only see threads and messages in the currently selected language, which is determined by their browser. Please create an account and log in to see all content by default. This is a limitation of the forum software.


Also users that are not logged in can not create new threads. This is a, unfortunately needed, counter measure against spam. Please create an account and log in to start new threads.

Don't Panic. Please wash hands.
  • On 9o firmware but have had these things happen on 9n firmware too:

    1. When hooked into a breadbin C64 (UK PAL), i'm finding that an SD2IEC can't seem to be active in any capacity at the same time as having drive emulation on via cart port with the TCV2 drive ID at 9 (i don't have the cable to hook the TCV2 into the IEC port to test IEC connection of the TC) without major issues in terms of access because SD2IEC reads become intermittent at best and almost impossible at worst. once i turn off internal connection of the emulated drive, it allows the SD2IEC to work correctly but without the emulated drive. same goes if i make the emulated drive 8 and the sd2iec drive 9.


    2. I'm finding that a couple of demos refuse to load correctly at all - desert dream reaches the "loading demo..." screen and just infinite loads. and edge of disgrace just crashes. i've checked the d64's work in VICE just fine so it's not my images and i've also tested with stock C64 and jiffydos kernal and 1541 drive roms and with/without any fastload carts with no change in DD and with varying points of crashing in EOD.


    3. is there any easy way to copy files between SD2IEC and TCV2 on hardware rather than SD card juggling via PC? (i.e. create a blank D64 either on SD2IEC via TCV2 or create a blank D64 on TCV2 and then copy over to SD2IEC). i've tried the file creation basic programs i found on (i think) lemon64 and while they work, i found that they mess around with the file order on the sd2iec and i then have to take the sd card back to pc and fix it there (i know the sd2iec isn't your hardware so i'm not expecting for you to come up with fixes for the file order thing)


    4. Does the MMC64 functionality have any sort of advantage over the built in TCV2 file browser (especially when paired with an SD2IEC)?

  • Just a quick answer now, i'll have to check with sd2iec tomorrow:


    1. generally sd2iec should "just work". try resetting the chameleon settings to default and try again. also please tell what kind of sd2iec hardware you have there.


    2. is odd - again try resetting the settings. it should work


    3. you can do it in the file browser (see the manual on how to enable two-panels mode). however, if sd2iec doesnt work in your setup then this will be tricky :)


    4. generally, no. MMC64 functionality really only exists for us to debug things when something goes wrong. and some MMC64 plugins exist that are not reproduced in the chameleon filebrowser yet (like playing mp3 with mp3@c64)

  • getting a chance to pull my C64 out again will take a bit of time (children, wouldn't you know) so i'll have to post again when i'm able to do so on the SD2IEC front (though mine was ordered from tfw8b and is running a very recent version of the firmware since i updated it as part of the troubleshooting i did). and resetting the to default did fix the demos and allowed me to narrow it down to my REU/GeoRam settings. And i'm aware of the two panel options but i'm guessing until i can get the SD2IEC to co-operate properly with the TC, i can't do more.

  • just pulled my c64 out again and tried the sd2iec with the default reset settings and somehow it is working now. the only remaining issues are how the filebrowser that comes with the sd2iec doesn't want to work with the retro replay rom (dirplus and sdbrowse do thankfully) and the TCv2 filebrowser just sees the sd2iec as a literal drive 8 so it doesn't even try to allow for sd filesystem to sd filesystem copies.

  • Quote

    the TCv2 filebrowser just sees the sd2iec as a literal drive 8 so it doesn't even try to allow for sd filesystem to sd filesystem copies.

    well, of course, that is expected behaviour.