Indivision ECS V2 display issue

Caution: Non registered users only see threads and messages in the currently selected language, which is determined by their browser. Please create an account and log in to see all content by default. This is a limitation of the forum software.

Also users that are not logged in can not create new threads. This is a, unfortunately needed, counter measure against spam. Please create an account and log in to start new threads.

Don't Panic. Please wash hands.
  • Hi Jens,

    Thank you very much, I was able to solve the problem and my IndiECSv2 is already working again.

    I unzipped the flashtool-1.7.lha file in WinUAE, I created an ADF image of a boot floppy.

    I started the AMIGA 500 rev. 6A - 1MB chip RAM, with the ADF image, the computer booted, and apparently reflashed the IndiECSv2.

    Power Led Blinking once, pause, repeat, meaning, "Success, all ok".

    I restarted the AMIGA and no image on the monitor, which continued to indicate "no signal detected".

    I reflashed it several times and the result always remained the same until I remembered to connect my old CRT PHILIPS monitor to the VGA output and my Benq LCD monitor to the AMIGA RGB output.


    Somehow IndiECSv2 woke up and from there I got everything working again.

    Thank you again, Jens, for your support!

    Palma Santos

  • Hello JENS, i have the same problem with my brand new ECS, but it's on an Amiga 1000, with the proper paula socket extension, when I boot with paula seated on the expansion socket and Denise, it boots correctly to the kickstart disk image, but when I pullout the Denise chip, and seat the ECS into the paula expansion, screen is grey then turns black when it should display the kickstart hand. The problem is that I have no rescue disk, and even with one, I have to first play a kickstart disk blindly then the rescue disk wish seems problematic for me...

    Do i have to resend you the ECS board ?

    Thanks for your information .

  • If you insert the Paula adapter on the Paula chip, then of course the Denise chip must stay in it's socket. Indivision ECS V2 just sits in the socket on the Paula-adapter, but there is no Denise chip on Indivision ECS V2 in that config. Your mistake here is clearly that the Denise chip is missing from the computer.

  • Hi Jens,

    I already tried also this configuration, and tried again today, when Denise chip is socketed, I have a good kickstart hand screen if I check on the normal output, but still nothing on the db15 ECS output, it remains black. (P.S. when I talk about the normal output, it's the composite output linked to an external upscale, so I know the vga entry of my lcd screen works...)

  • and some others...

    The kickstart screen is taken from the composite output of the A1000, the black screen is the VGA output of the ECS (P.S. the composite picture goes trough an external VGA upscaler so I know the screen works...)

  • so the machine is running, but only the picture from Indivision ECS V2 is not there. Was this "out of the box", or did you run the config/flash tool at any time?

  • OK, so the computer is launched with the early startup ROMs - these may write to the Denise registers earlier than the FPGA is configured after power-up. This means that the Denise inside Indivision misses the information about what colours to set for example.

    Please try to do a keyboard reset after the drive starts to click (indicating it is waiting for the Kickstart disk). This may already bring the picture up on the VGA output of Indivision ECS V2.

    A keyboard reset is given by pressing and holding these three keys at the same time: CTRL, left Amiga-key and the right Amiga-key. After you release this combination, the computer will restart.

  • Do you have a second Amiga to try this with? Maybe take a close look at the pins of Indivision ECS V2 - something broken off?

    All Indivision ECS V2 pass a single-unit-test before they leave here, so I have my doubts that it was "dead out of the box". We're most likely looking for a different source of the problem if you also never attempted to flash it.

  • Hello Jens, some good news today, I received my Cloanto kickstart and workbench disk today, so I tested it for starting. The behavior is as follow, when I boot the computer without disk, I have a black screen, I then insert the kickstart disk that loads correctly, when it ask for the workbench disk, then I see the workbench disk on screen, the ECS is working correctly. So has you said, it's probably a timing issue at startup between the A1000 and ECS board, it is resolved when the A1000 resets to Workbench screen. I am very happy, because the quality difference for the screen is tremendous between a simple upscale and the ECS, you really enjoy the difference. Thanks for your help and patience.:):thumbup:

    The fact that I don't see the kickstart disk at start is a very minor issue for me because at some time I will upgrade to another type of kickstart...

  • The last reply was more than 365 days ago, this thread is most likely obsolete. It is recommended to create a new thread instead.