VIC and CPU not detected after a few minutes

Caution: Non registered users only see threads and messages in the currently selected language, which is determined by their browser. Please create an account and log in to see all content by default. This is a limitation of the forum software.

Also users that are not logged in can not create new threads. This is a, unfortunately needed, counter measure against spam. Please create an account and log in to start new threads.

Don't Panic. Please wash hands.
  • Hi all,

    I’ve had a c64r mk2 since november 2019 and it worked very well until today.

    When I start the computer, everything works fine.

    VIC-II: 8565 (7F 00 AF55 PAL)

    SID 1 : 8580 (DE 00)

    SID 2 : 6581 (A0 CA)

    CPU : PHI2 OK (0457)

    MCU : 20180227

    But after a few minutes, i have a black screen.
    A remote chipset detection gives me this output :

    Error: VIC-II is not recognized, check U19.


    VIC-II: Unknown (D9 D9 0000 PAL)

    SID 1 : 8580 (D1 00)

    SID 2 : 6581 (8E B0)

    CPU : Unknown (08CA)

    MCU : 20180227

    Can you help me with this?

  • Chip recognition largely depends on a proper power supply. What type are you using?

    Further, it might be a simple contact problem. Just move the chip(s) sideways while the sockets are closed (lever down), this will scratch the pins a little, improving contact.

  • for the PSU, I use the one you sell.
    I already tried to remove the chips and cleaned the pins but the issue came back after a few minutes.

    I also tried to replace the VIC chip with the one installed in my real C64 ou to use another PSU.

  • It's not entirely impossible that a PSU fails after a few years of usage. Do you have a volt meter, can you check voltages on a few spots of the board?

    What's the warranty ID of the baord?

  • The voltages that you've measured are "behind the DC-DC converter", so not good for telling if the PSU is deviating from the specs. Please measure between one of the mounting holes (they are all connected to GND) and the big F1 part (either side - near the switch) to measure the input voltage from the PSU.

  • If that's measured while the board did not find the chips properly, something else is wrong. For judging if this is a contact and/or chip problem, we'd need the board with the chips that you're using. Before you ship anything, please read this article, so the shop employees know what to do with your board (they do NOT read this forum!).

  • Hi Jens,

    I did some tests this weekend.

    I first swapped the VIC with that of one of my real C64s. The C64R got back to work. I was able to run a few games and demos. So I thought the VIC was faulty and started testing the real C64. But it works flawlessly and I ran the Dead Test 781220 cartridge for 8 hours with no issues.

    There, I thought to myself that there must be something weird in the C64R. I ran the Dead Test cartridge on it and saw that maybe I have a problem with one of the CIA chips. After a few cycles, the test no longer displays the same time. At first it was after 2 or 3 cycles and after cleaning the chips pins, I can go up to an hour.

    So I'm not going to send the card back now. I will first fix this problem with the CIA chip before.


  • The last reply was more than 365 days ago, this thread is most likely obsolete. It is recommended to create a new thread instead.