Indivision mk3over heating

Caution: Non registered users only see threads and messages in the currently selected language, which is determined by their browser Please create an account and log in to see all content by default. This is a limitation of the forum software.
Don't Panic. Please wash hands.
  • Hi when I use my Amiga for over 30 minutes the screen distorts a little

    The indivision mk3 gets hot

    Is there a solution to keep it cool.
    I have installed 3.1.4 roms

    Ka60 32gb sd adapter

    Blizzard 060 with scsi kit IV with a cd rom connected

    A Goliath power supply

    All runs on without indivision mk3

  • First question: Are you running the exact same resolution if you're trying with/without the flicker fixer? You may just be looking at something that your A1200 renerates, and the flicker fixer makes it visible. So if you're comparing, please make sure that both are using the same screen mode.


    A Goliath power supply

    That may be your culprit - the heat is not a problem, as long as the unit does not exceed 85 degrees celsius (which it does not, even if you're packing it in insulating foam).


    Please read our PSU FAQ - your PSU is probably violating at least one of the three key specifications that Commodore gave for their PSUs. My expectation is that a proper PSU will solve your problem. The short version of the linked article is: "Power rating is not everything" - an Amiga requires very elaborate regulation to work 100% reliably.

    • :)
    • :(
    • ;)
    • :P
    • ^^
    • :D
    • ;(
    • X(
    • :*
    • :|
    • 8o
    • =O
    • <X
    • ||
    • :/
    • :S
    • X/
    • 8)
    • ?(
    • :huh:
    • :rolleyes:
    • :love:
    • 8|
    • :cursing:
    • :thumbdown:
    • :thumbup:
    • :sleeping:
    • :whistling:
    • :evil:
    • :saint:
    • <3
    Marks thread as resolved after post creation.