Intermittent error ACA1233n

Caution: Non registered users only see threads and messages in the currently selected language, which is determined by their browser. Please create an account and log in to see all content by default. This is a limitation of the forum software.


Also users that are not logged in can not create new threads. This is a, unfortunately needed, counter measure against spam. Please create an account and log in to start new threads.

Don't Panic. Please wash hands.
  • Hi There,


    I have an intermittent issue on my ACA1233n that appears after some use of my A1200. Sometimes I will be playing a game, or using workbench and the computer will freeze. Then I get the following error when I restart (see picture).


    Specs are:

    A1200 1D4

    ACA1233n-26
    MapROM 3.1.4
    CF IDE Card adapter
    Amiga OS 3.1.4 (installed using HSTWB Installer)

    Commodore PSU (STP 110 by Speedytech)

    This issue is hard to replicate or repeat. Sometimes I can get hours of use out of it before this occurs, so I think the Accelerator is working fine. Do you think it could be related to my PSU?

  • The autoconfig board in question is the memory of the accelerator. I've never had any bad memory chips, but I did have flaky power supplies causing funny behaviour with little to no real explanation possible about what's happening. First thing I'd do would be measuring the 5V rail inside the computer - if you have a multimeter with good-enough accuracy.

  • Hi Jens,


    Thank you for getting back to me over the Christmas break.


    I have measured the voltages from the floppy power connector with my multimeter and I am getting stable readings:


    4.99V on 5V

    12.28V on 12V

  • A multimeter is not exactly the right tool for measuring ripple and step response. While you can't measure these things, only a re-cap of the PSU or a cross-test with either a known-good computer or at least a known-good PSU is what will give you hints at the location of the cause.

  • Hi Jens. I could take it to my local Amiga User Group meeting for a test.


    Another idea I had was plugging it into my A500 via an ACA500plus? I do have another Amiga PSU I could try.

  • ACA500plus is a good test, yes. And if..:

    I do have another Amiga PSU I could try.

    ...that PSU is really an Amiga PSU (and not sold with false advertising, like many others on the market that are Meanwell-based), then this is of course yet another good test.

  • I know that with regards to original Amiga 500, 600 and 1200 power supplies they come in 2.5A, 3A and 4.5A variants for +5v. When I was using my ACA 1233 in my ACA 500 on my A500s I had to use the 4.5A variant. 3A variant would not even boot the system.


    If I remember correctly, when using the ACA 1233 in my A1200 it would boot with the 3A power supply. did not test any further, but I can imagine it would have given me stability problems. I currently use the 4.5A variant for my A1200 with ACA 1233 which of course works just fine.


    According to some googling the 4.5A variant is the so called 'type 2' Part number: 312503-03) and it came with many A500s.

  • There are too many COmmodore PSUs with too many different electronics. Further, after all these years the output capacitors should be exchanged for new ones, and the voltage adjustment should get a fresh tuneup - remember these were adjusted over 30 years ago, and components have run through MANY temperature cycles by now. Whatever has been adjusted then is definitely off now.


    If you don't feel comfortable working on power supplies (as the high voltage in there can be dangerous to your life!), you should look at our CA-PSU. The only one on the market that does real-time voltage adjust ment for voltage drop on the cable and the input filter of the Amiga.

  • Yes. I have started recapping several of my old Amiga PSUs. One of my A600 powersupplies (3A on +5v) was smelling fish. It had leaky caps. I could also see some interference in the picture when using this PSU. After recap all is well.


    Another A500 supply I recapped also had a leaky cap. Fishsmell as I unsoldered it. And corrosion on the pads.

  • Don't forget to adjust voltage under full load, measure *inside* the computer.

    What are your thoughts around A500s caps? People say they almost never leak. I recap them anyway. Not seen or smelled any leaking caps thus far, after recapping probably 8 or 9 A500 boards. A600, A1200 and A4000 is another matter of course.

  • What are your thoughts around A500s caps? People say they almost never leak.

    And they are right. Ceramic caps do not leak, and the few electrolytics inside the machine don't get high ripple voltage. Further, they did not go through a reflow process where the whole thing was heatet to soldering temperature. Instead, only the pins were exposed to heat, considerably improving their life span.


    Don't repair it if it ain't broke.

  • Hi Jens,


    I did a memory test for 3 hours on the A500 and then ran a bunch of WHDLoad games for another 3 hours... never skipped a beat.


    I think the accelerator is fine, it must be my A1200 or my PSU.


    Thanks for you help,


    Owen

  • I just want to add my experience with ACA1233n because there might be others out there who might face the same thing.


    I guess I'm not the only one to get inspired and try to get an old Amiga 1200 up and running again after many years. I had an old accelerator card but without ram SIMM... and I remember it as a pain to use because there were special drivers disk and not a hint of autoconfig. So I ended up getting something that is readily available on the market and that I could actually get in a specialty shop in my town - the 1233n.


    Symptoms....

    All seemed well and I had excellent audio and video, but after using the 1200 for some time I would get crashes, or WHDLoad games freezing or not starting. One example that without exception froze shortly after entering the 3D mode was F/A 18 Interceptor. Lowering the CPU frequency or turning off the card using the ACATool would improve the situation for many games and Workbench but never F/A 18 Interceptor. I tried all possible configurations of WHDLoad and never got it stable.


    Resolution...

    Recap. That's it.

    I disassembled the 1200 and sent my motherboard to a person in my country Sweden who recapped my Rev. 1D.1 board and did the timing fix (removing E123C and E125C). It solved all stability problems as far as I can tell.


    Not going to lie - I don't like disassembling/re-assembling the hardware and waiting for the job to get done, but in the end I'm just really happy with the result. Now I can run my 1200 on max CPU frequency without any problems with heat or instability. Also with the "new" Compact Flash cards the machine is really the fastest and most responsive it has ever been.


    Regarding heat - have you also owned an accelerator card that required an extra fan (not supplied from vendor) or removing the trapdoor lid and lifting the 1200 up with handmade spacers? ^^ Thankfully, those days are gone.


    /Fredrik