Indivision ECS (2009 model) repair

Caution: Non registered users only see threads and messages in the currently selected language, which is determined by their browser. Please create an account and log in to see all content by default. This is a limitation of the forum software.


Also users that are not logged in can not create new threads. This is a, unfortunately needed, counter measure against spam. Please create an account and log in to start new threads.

Don't Panic. Please wash hands.
  • Hello iComp


    My Indivision ECS failed with no image at all. The monitor receives something because when I turn the Amiga on, it goes out of sleep mode but the screen remains all black. After inspection I noticed a component is missing. I have no idea how I managed to do that but anyway... it is missing and I guess that's the reason (Please see attached picture).



    Can you repair it if I send it? I ask because it is the old model so I don't know if you still offer repair service for it.


    Also, I read on another thread on this forum about a fix to make it more tolerant to ripple from the PSU. There are some pictures on that thread and looks like mine does not have such a fix. Can the fix be applied as well?


    Thanks!

    Efren

  • That missing component is a ferrite bead, 1206 size, 56R@100MHz. We do have these, and we can offer a repair. If you want to attempt a "quick fix", you can just use a wire bridge on the missing component, as the cause of the failure is that power is not passed through the device.


    We can of course also add the "ripple fix" if you decide to send it to us. This is "most needed" if you run one of those bad MeanWell-based PSUs, which I highly recommend to replace with a CA-PSU.


    Anyway, age is not an issue, we do service older units. There is no planned obsolescence at iComp. Please read this article before sending anything back.

  • Hello Jens


    Thanks. I think I'll be sending it togheter with at least one more item (X-Surf 500). I use an original Commodore 4.5A PSU which I recapped 2 or 3 months ago, but depending on cost, I think I would like to have the ripple fix applied anyway.


    About the CA-PSU, I am just waiting for the 110V version to be available. With any luck, I'll send my items to repair and they'll return with their new CA-PSU friend :P


    Thanks!

    Efrén