X-Surf 500 Damaged?

Caution: Non registered users only see threads and messages in the currently selected language, which is determined by their browser. Please create an account and log in to see all content by default. This is a limitation of the forum software.

Also users that are not logged in can not create new threads. This is a, unfortunately needed, counter measure against spam. Please create an account and log in to start new threads.

Don't Panic. Please wash hands.
  • Hello iComp!

    I tried to use my X-Surf 500 after a few months of not using it (it has remained attached to my ACA500plus all the time, just without ethernet cable) and looks like it does not work anymore. The activity leds never turn on. Not on the XSurf-500, not on the router. I know the cable and router work fine beccause that same cable provides internet to a windows laptop next to the Amiga.

    The card worked fine since I bought it. It is just now that it refuses to work and I'm afraid something might be damaged on it. Maybe I inadvertently did something I shouldn't... I don't know. :(

    The ACA500plus finds it and reports the MAC address just fine (pressing TAB on the start menu). It just acts as if the ethernet port were disconnected. Needless to say, no connection can be established from the OS.

    Is there any advice on some tests I can do or something to review? and if it ends up being damaged I guess I woukd like to send it to be repaired, if possible.



  • First thing I'd try is removing the board and re-attaching it, but that will only solve a problem on the connection between ACA500plus and the X-Surf-500, which appears to be OK if you say that the MAC address is seen properly. If there's nothing obvious on the card, maybe a mechanical defect, a component ripped off, a pin inside the RJ45 bent, then a repair here may be required.

  • Hello Jens

    Thanks for your reply. I tried disconnecting and reconnecting the board but as expected, nothing changed. I did a visual inspection and the only unusual thing I could find was that 2 solder points for the JR45 seem to be different than the rest. Looks like they were resoldered after the card was manufactured. Please see the attached picture. I did not resolder anything. The card is exactly as I received it from iComp store.

    So, my theory now is that maybe those 2 points were resoldered because contact was not perfect and now the solder has lost contact (after several connect / disconnect cycles). I can try and reflow, remove the existing solder and apply new one just on those 2 points, but first I would like to know your opinion on that. Also, I could check for continuity but I cannot see where those tracks go in the board. Have you had cases before where this resolder was needed?

    I hope this the whole issue, sounds like an easy fix if it is.



  • Have you had cases before where this resolder was needed?

    We do visual inspection on all cards before functional testing, so yes, such a touch-up is likely to be done here. With the connector being exposed to external forces, it's not unlikely that it fails under certain conditions, so if you have the tools and skill to re-solder the pins, this might save you the "downtime" of sending it here.

    Don't attempt to remove old solder and apply new one - that's too complicated. If it's really a broken solder joint, then heating each pin and letting it freeze again will do the trick.

  • Hello Jens

    Well I did reflow all pins: Added a little flux, heat pin until the solder melts, remove iron tip, repeat. Unfortunately nothing changed. Boot menu can still see the MAC address just fine but there is no activity on either side of the cable and of course, connection cannot be established from the OS.

    I think I'll be sending this and my Indivision ECS (different thread for that) together. I also have an Indivison AGA MK2 I tried to use yesterday on an A1200 that did not work at all, but I'll open a separate thread for that.

    Maybe I'll end up sending the 3 items in one go.