Rapidroad USB for X-Surf-100 help needed!

Caution: Non registered users only see threads and messages in the currently selected language, which is determined by their browser Please create an account and log in to see all content by default. This is a limitation of the forum software.
Don't Panic. Please wash hands.
  • Hello folks!


    i’ve revived the old lady, and i need some help to setup the RapidRoad USB for X-Surf-100!


    Hardware present and fully working:

    A3000 with 16 Megabytes of ZIP RAM

    GVP T-Rex I with 32 of RAM

    Buster 11

    Indivision ECS 1.0

    X-Surf-100 + RapidRoad USB for X-Surf-100

    Picasso IV


    I’ve done a clean install of 3.1.4, and updated it to 3.1.4..1 on real ROM’s.

    Mui 3.8 installed and running

    Poseidon Installed (partially running!)


    So, everytime i try to run the Trident Config i get a recoverable alert.

    I can’t run the thing, so cannot configure the usb.


    Any tips on how to fix this?


    Many thanks!


    Pedro

  • OS 3.1.4 makes use of the MMU, which is always present in the 68030 of the A3000. You need to use the latest driver that can handle the MMU. In simple terms, it must "poke a hole" into the protective layer before it can work. Only V1.7 of the driver can do that.

  • Poseidon is developed on/for OS3.1, and OS3.1.4 came later - I suggest to check with Hyperion to find out if there's something special you need to do in order to make it work on 3.1.4. I can't support that here, so the only thing I can recommend at the moment - just to find out if the hardware/driver part is working - is to go with a clean 3.1 install to see if there's a general problem with the hardware, or just a minor issue that can be solved on the OS 3.1.4 side.


    I do know that other people are using Poseidon with OS3.1.4, so there's no "big show stopper". However, I still have a "hid.class" update pending that needs to be published, which fixes Autorepeat on USB keyboards. Took the chance to dig that out now - binary to be released in a few days.

  • I have an A2000 with a GVP 030 @ 40 MHZ, X-Surf 100 and Rapid Road with MUI 3.8 and Amiga OS 3.1.4.1 (Kickstart ROMS 3.1.4) and it all works fine. I'm wondering if it's the CPU libraries you are using. if any. I am using Thor's CPU libraries (the 030 library is a small one) on all my machines with no problems. The only other time I have had weird guru's or recoverable alerts is with bad RAM. Maybe do a RAM test just incase. Good luck with it!

  • Hello guys!


    I’ve managed to make it work!
    Took me some time to do it but...

    So, i remove the 3.1.4 ROM’s and reinstalled the trusty old 40.68 chips :)

    Fully installed Workbench 3.1 on a clean (formatted) hdd, mui3.8, mulibs, poseidon and voila!
    THEN, installed Workbench 3.1.4 and then the update 3.1.4.1.

    Finally removed the old roms and put the new 3.1.4 ones.


    Works as a baby now!


    Tried usb pen’s, keyboards and usb mouses.


    All is good and this post can be closed!



    Thank you all!


    Pedro