CA-PSU won't power up my A1200 but powers up my A500's

Caution: Non registered users only see threads and messages in the currently selected language, which is determined by their browser. Please create an account and log in to see all content by default. This is a limitation of the forum software.


Also users that are not logged in can not create new threads. This is a, unfortunately needed, counter measure against spam. Please create an account and log in to start new threads.

Don't Panic. Please wash hands.
  • I do feel disappointed though.

    I can totally understand that - I do see that you've bought all the latest devices from us, and of course I'd like to get to the bottom of this. Maybe it's just the inrush current that makes the CA-PSU believe there's a short - one last attempt could be that you remove either the accelerator or the flicker fixer and see if it powers up.


    Also, is the A1200 re-capped?

  • Yes, I've tried without the accelerator. Initially when I first threw it all together, the accelerator was out and I did pull the Indi MK3 out as per my original post when nothing worked.

    Recapped the A1200 in January this year when I acquired it.


    But to put be sure, I just pulled everything out, including the IDE to CF with no change in behaviour. Then plugged my A500 PSU and it started. I did have the LED header plugged in to see if anything was happening. Even the keyboard was disconnected on this last test.

  • I bought a kit from AmigaKit. Is there specific caps I should look closer at? The surface mount ones or the through hole?

    I didn't pay much attention to them when I put them in, just made sure the polarity was good and everything was cleaned.


    I can recap again if you think that may be the issue...I really hope that it is.


    I can't even see what brand these are without pulling them.


    Any recommendations?

  • The last reply was more than 365 days ago, this thread is most likely obsolete. It is recommended to create a new thread instead.