CF card to IDE doesn't work with original X-Surf

Caution: Non registered users only see threads and messages in the currently selected language, which is determined by their browser Please create an account and log in to see all content by default. This is a limitation of the forum software.
Don't Panic. Please wash hands.
  • To save others from spending time trying to get this to work: I have done enough testing to safely say that connecting a CF-to-IDE adapter to the IDE ports of the original X-Surf doesn't work, in an Amiga 3000, at least.


    I have tried with both IDE ports on the X-Surf, two different CF-to-IDE adapters and six CF cards. None of them are recognized in anyway, for instance by HDToolbox.


    Note that the X-Surf IDE driver uses scsi.device, which the A3000's SCSI adapter also uses. But, the Commodore engineers were smart so the X-Surf IDE device is renamed to 2nd.scsi.device.


    I do see the activity lights on the adapters flash during boot and when HDToolbox scans the devices.


    When I connected an IDE harddisk, that worked just fine. So it's an issue with CF cards, not an issue with the hardware or drivers in general.


    I have a Buddha card on the way because I want to be able to boot from a solid state drive, so for me this is not an issue, I just thought I'd write this down just in case it's useful for someone else.

  • This is a known issue: The drivers for the old X-Surf card are written by Elaborate Bytes, and they contain all the removable-media-support that the old Buddha also had. This includes that whenever a "removable" device is seen, it will fork into the ATAPI code path for ZIP drives and the like. That's where the CF cards won't answer any more, as they talk IDE, not Atapi.


    There's actually a patch in Aminet that switches off the removable media support. I don't really recommend it, but it may be a solution for you.


    The new Buddha drivers will boot from CF cards, even if they report to be "removable". However, the new Buddha drivers don't support ZIP and LS120 drives any more.