AGA Mk3 & Panasonic drives

Caution: Non registered users only see threads and messages in the currently selected language, which is determined by their browser Please create an account and log in to see all content by default. This is a limitation of the forum software.
Don't Panic. Please wash hands.
  • Very much considering 1 (or maybe even 2) Mk3s. However I read that two fellow Dutchies encountered problems with the Mk3 in combination with a Panasonic JU-257A516P floppy drive. The drive is not recognised anymore when the Mk3 is installed (DFO:????).…ocht-diskdrive-voor-a1200.

    When they tried with a different type of drive all worked fine again.

    Anybody else with this drive? What is your experience?

    Since my two A1200s also have this drive I'm reluctant in buying an Mk3 for now.

    Hope you can reproduce and fix or help troubleshoot/pinpoint this Jens, thanks in advance!

  • I have no idea how the flicker fixer can have an impact on the floppy drive - other than a bad power supply. I don't speak Dutch, so if proper power supply readings haven't been made there, I don't trust random "this doesn't work" reports. Yes, the MK3 might be the thing they installed last, but no, the MK3 is not the cause - it may be what tipped the scales, but you may have installed something totally different and ran into the same problems.

  • Does the CIA adapter connect to the CIA that also takes care of the floppy drive?

    No - the CIA we go on is the one for the parallel port. Floppy signals are handled by the other one. Like I wrote yesterday: I don't have any immediate explanation for a floppy drive failure, other than the power supply acting up. I wouldn't be surprised if one of these known-bad MeanWell-PSUs are the cause.

  • Then I agree with you that it seems really odd there is a relation between this type of drive and Mk3 not working. At least one of the 2 people uses its original PSU. Just hoping some people here can confirm a working Mk3 with Panasonic drive :)

  • FYI I experienced the following issue with my Chinon FZ drive:

    * Drive stopped responding or reading disks with MK3 installed, also had 'sparkling' pixels on the display.

    To fix:

    I re-capped my floppy drive & moved the Mk3 ribbon cable further away from the floppy drive. Seemed to solve the problem. I also slacked off the floppy screws (the two on the outside of the case, under the back end) As having these tight caused friction between the motor spindle and bottom floppy shielding.

    I know MK3 is not to blame here. But for what ever reason I needed to service the floppy after the install.