C64 Reloaded MK2, Ultimate 1541 and a 1541-II

Caution: Non registered users only see threads and messages in the currently selected language, which is determined by their browser Please create an account and log in to see all content by default. This is a limitation of the forum software.
Don't Panic. Please wash hands.
  • I'd just use two drives and see how the chain behaves if you have one of the drives switched off - and of course a possible difference between C64RMK2 and an "original" unit. Please use the PSU that outputs "closer to 5V", so we bring the two boards closer to each other in terms of voltage.

  • I will try to reproduce it here....


    can you point to a picture of the exact 1541UII model you have there? I have all of them here, but i dont remember exactly which is which =)

  • OK so, what can i say. It works for me :)


    my Setup looks like this:


    C64RMK2->1541(old)->1541II->1541UII+


    both real drives turned off, i can still load fine from the 1541UII.


    I think we are going into vague (almost esoteric) territory now... a lot of things could make this better or worse, the type (and length) of IEC cables, ground loops, i dont know.


    I misplaced my Multimeter, will do some searching now :=) Jens: What exactly should i measure? Storm: what exactly were you trying to load and how? i have tested a random d64 and used kernal load (not AR or sth like that) - is that enough for you to reproduce the problem?


    Edit: i am measuring 4,95V at CIA1 and 4,92V at CIA2

  • C64RMK2->1541(old)->1541II->1541UII+


    both real drives turned off, i can still load fine from the 1541UII.

    The way I got Storm's setup was that he only had a single "real" drive on the bus.


    What exactly should i measure?

    The low-level is something you'll only be able to measure with an osciloscope, as that'll be fast transitions only. The idle level is high - just write down all IEC signals idle voltage.


    One thing that Storm might check is the setting for the IEC Burst in the remote control menu: Is that maybe switched on? This might have an effect on functionality with this on-the-edge-setup.

  • Hi guys, I just got in from work so I will set the experiment up shortly, after a coffee of course ;)


    Tobias I noticed you have the Plus version. Mine is the version before, the non-plus with firmware 3.7 installed (latest).

    The way I was trying to load is first to mount a .d64 image and back to the C64 for the usual LOAD"*",8,1

    This is where is fails but if you do a mount+run it works, although I didn't try a multiload program for this.

    So my other tests were done using C64MK2 -> 1541-II -> Ultimate 1541-II. Both IEC cables being the same standard length.


    Jens I will connect my laptop to C64MK2 and see what setting are in place, like IEC Burst. Back soon with more results.

  • Okay, back with some interesting results.


    I used a 1541, 1541-II, 1541-II with JiffyDOS kernal, 1541 Ultimate 2.

    All IEC leads were the same standard length.

    C64 Reloaded voltage was 4.91

    Original C64 voltage was 4.98


    C64MK2 -> 1541-II (ON) -> 1541 (OFF) -> Ultimate = working

    C64MK2 -> 1541-II/JDOS (ON) -> 1541 (OFF) -> Ultimate = not working

    C64MK2 -> 1541-II (OFF) -> 1541 (ON) -> Ultimate = working

    C64MK2 -> 1541-II (OFF) -> 1541 (OFF) -> Ultimate = not working


    I tried the C64MK2 with JiffyDOS enabled and disabled, same result. IEC Burst is default, being off.

    You can tell when it's not going to work as the red LED on the Ultimate stays on.


    Original C64 - all tests worked.

    Just out of coincidence stumbled over this :)

    Interesting. Apparently my one has a MOSFET in it (Don't ask me, all I know is what it stands for lol).

    Mine drops the voltage by approx. 0.04V. Probably a few different designs out there.

    I didn't use it in these tests.

  • OK, i made another interesting observation....


    First, i changed my cabling to match yours, ie


    C64MK2->1541-II->1541-Ultimate


    now, i switched the two real drives to #8, and powered both OFF. The U2+ set to drive 9. This works. Then i swapped the U2+ against U2 - and it stops working. IMHO that again shows that we are in vague territory here, something is really "on the edge".


    Will try to do some measurements with U2+ and U2 now....

  • So, some numbers.... to me it is pretty obvious the powered off drive is pulling down the lines:


    i measured against the mounting hole at the bottom left of the C64RMK2, and then put the probe at the backside of the IEC plug in the following order: top left, top right, center, bottom left, bottom right. not sure what signals relate to that (and one is missing). the result looks like this:


    with the 1541U2 (non plus):


    with 1541-II powered ON: 4,94V - 3,90V - 2,73V - 0V - 0,12V

    with 1541-II powered OFF: 3,07V - 0,14V - 0,62V - 0V - 0,08V


    with the 1541U2+:

    with 1541-II powered ON: 4,94V - 3,90V - 3,37V - 0V - 0,10V

    with 1541-II powered OFF: 3,08V - 2,79V - 1,97V - 0V - 0,10V


    Not sure what to do further, seems obvious that also Gideon noticed something can be improved there :)

  • Hi! This is Gideon here... I was asked my opinion about this matter privately, but I feel that it is right to post it here publicly.

    I fully agree on all technical grounds with Jens and Tobias from iComp. Having a device in the chain that is powered off is simply not a good idea. As Jens explained: this device will effectively place pull down resistors on the IEC lines, which compromises the logic high level. No need to pull more stuff out of the closet to test and "proof" something. Just turn the drive on or remove it from the chain. Not a problem of the Reloaded Mk2, nor the 1541 or derivatives.


    Gideon

  • I totally get what everyone is saying about the technical side of this, I wasn't going to debate this as I'm certainly no expert in this department. It's more of a curiosity rather than a problem. Fact remains - that it does work on ALL my original hardware, regardless of the technical reasons, and I was just interested in why this was so. I did enjoy the investigation, but now we are done.


    Now I will have to rummage through some more retro gear and see what next I can pester Jens and Tobias about ;)