RTC Module on a ACA1233N-40

Caution: Non registered users only see threads and messages in the currently selected language, which is determined by their browser Please create an account and log in to see all content by default. This is a limitation of the forum software.
Don't Panic. Please wash hands.
  • Hi, I have recently bought a Real Time Clock module and fitted this to my ACA1233n. Initially my Amiga 1200 did not boot but after re-fitting everything again it booted.

    I then set the time and date via workbench. However when I powered down and left the Amiga switched off for 20mins I loaded up again and noticed the time had not saved using the real time clock however the date had saved. So I set the time again and before I turned the power off I decided to check the ACA1233n to see if it was behaving ok.

    What I got was half the speed nearly when running a speed test. The speed was 5567 dhrystones where as I normally get 9201 dhrystones or else 9061 dhrystones. It is never this slow. So I decided to power the Amiga off again anyway and check later on if the date and time had saved.

    The did not save. Both date and time where incorrect on bootup. So I figured there is something wrong with the RTC module I bought (it had a battery already fitted). I then went to check the speed of the ACA1233n and I noticed I was still getting slower speed than normal when the CPU was set to 40mhz. The speeds I was getting in sysinfo this time where 8567 dhrystones and fluctuating back and forth to around 9060 dhrystones.

    So I then removed the RTC module. When I booted the Amiga 1200 again to check the accelerator without the RTC the speeds where normal and I got 9201 dhrystones over a period of an hour consistently.

    So I am wondering would a faulty RTC cause such issue with the ACA1233N card?

    The seller of the RTC also would like me to check the RTC module using the Amiga 1200 RTC header on the motherboard, however am I correct in my understanding that the Amiga 1200 RTC header cannot be used when you have a ACA1233n installed?



  • Just a bizarre update to report with this, my Amiga is reporting in sysinfo that there is a clock found. Which of course there cannot be since I have uninstalled the clockmodule. Any ideas as to what this may be? A short circuit somewhere?

  • So I am wondering would a faulty RTC cause such issue with the ACA1233N card?

    No. The RTC signals on the header of the ACA1233n are purely generated by the A1200. The ACA1233n only passes them from the 150-pin connector to the clock port header.

    If you leave the clock port header on the ACA1233n open, you can of course use the internal header of the A1200 for the RTC.

    What you're experiencing in terms of speed changes observable in Sysinfo might be caused by Sysinfo just not being accurate - a few percent up/down is normal, depending on cache alignment. Larger speed changes would normally be caused by the card being clocked down, for example the CPU governour, in case you've ever installed that.

  • So I tried the RTC on the Amiga itself. It did not work. Could be the batter but either way I think it is a dud. Now the issue is that the Amiga reports a clock even when the clock module has been uninstalled. I realise this is probably nothing to do with the ACA1233n but I was just curious as it was on the card that I first tried the RTC.

  • setclock load

    setclock reset

    these commands don't seem to do anything. Which makes sense since there is no clock module currently installed. I still think it is weird that is appears in the sysinfo and in scout programs showing there is a clock installed. I even updated sysinfo from 3.26 to 4.3.

  • The setclock command displays nothing if I remember right. Only the "date" command after that will show a change.

    Still, no tool should display presence of a certain piece of hardware if it's not there in reality. The setclock command is from a time when the Amiga was fairly new, so I'd take the age of this as an excuse. However, you might want to explore why "something" is being displayed. Did anyone ever solder on the mainboard of your A1200? Can you take a picture of the clock port/chip ram area of the A1200?

  • No the only person who ever soldered anything to the main board was me and it was to carry out a modification to the RGB output. Basically a wire going from a resistor near the RGB output and soldered to my RF shield. I may not be describing this very well so here is a link to a picture of the mod.


    It's strange as I never had any clock module before in my sysinfo until I installed this RTC module the other day. Obviously as it was not working I removed it. I am looking for an old picture of my sysinfo to check this.

  • Ok couldn't find a screen shot of sysinfo saying I had no clock but I'm pretty sure it did not before I ever attempted to install one.

    I put the clck back on the ACA again and I tried something called "Restartclock" which is a program used to identify issues with an RTC and it of course through up errors indicating an issue.

    I've just ordered a new clock today to try it out instead.

    None of this of course explains the mystery of why it says I have a clock installed when I remove the module so I really don't know what else to try regarding that. I may get another RTC and find I still have the same issue but it's worth finding out I suppose.

  • You provided a few pictures, but unrelated to my request for a picture of the chipmem/clock port area of the A1200 main board. If you want me to look at this, please provide that picture.

  • Sorry I totally did not realise you wanted pictures.

    Ok so one positive thing so far, after getting a new battery the RTC actually WORKS! This is good.

    But it still doesn't explain why the RTC is detected even when I remove it!

    I will send you pics Jens sorry I missed your request.

  • I have them, just not physical versions. I bought the digital pack. This is why I was having issues using Acatool before as I had to take out my CF card to install new OS on blank card and it was just a nightmare. Workaround was to use HstWB image for 3.1.4 install which have a rom switcher function built. Not quite sure how it works but it is able to find rom for 3.1.4 on your HD and this is placed there during installation from the image. It's all a little confusing actually but I have made OS 3.1.4 installs a few times now spliced with Classic WB full and it's great.

    However as I have the rom files, a friend of mine is actually going to burn me chips as well. He's just waiting on blank roms.