Black screen after installing ACA1221ec

Caution: Non registered users only see threads and messages in the currently selected language, which is determined by their browser. Please create an account and log in to see all content by default. This is a limitation of the forum software.

Also users that are not logged in can not create new threads. This is a, unfortunately needed, counter measure against spam. Please create an account and log in to start new threads.

Don't Panic. Please wash hands.
  • Hi!

    I bought an ACA1221ec card last Friday and when I insert the card in my Amiga 1200 it doesn't boot up. The screen just goes black. I've tried with the jumper of as well but with no luck. I'm using kickstart rom 3.1.

    Can someone please help me?

    // Mattias

  • Tried that. Still doesn't work. Also tried to giggle it forward and backwards but with no result. The card gets warm after a while as well. Maybe that is normal?

  • Pull the ACA and inspect the card connector on it. My ACA1233n had mashed a pin, evidently due to the card edge snagging on it, and mashed it flat inside the connector. The result was a black screen.

    My lesson: check the A1200 edge connector (make sure it doesn't have any prominent dings or edges) and be sure the ACA is perfectly square to it as you slide it into place.

  • Don't mean to hijack, but I'm seeing a similar problem with my ACA1221ec, but only with a HSTWB scripted Workbench install. ACA1233n works with that copy of Workbench just fine, and the ACA1221ec works if the jumper is in "unprotect" mode. Obviously not a lot of acceleration going on in that instance, however.

    The ACA1221ec also works just fine with a copy of Workbench prepared by an ACA500+. I suspect it's a Workbench config issue with the HSTWB install, rather than a hardware issue, but I've no idea what it would be.

    Anyway, if you've not tried the "unprotect" setting for the jumper (as opposed to simply removed), give that a go and see if it makes a difference.

  • SpocksBeer: "Unprotect" merely keeps the large memory block from being added and the frequency from being set to 28.3MHz, so the card runs at a safe 17MHz. You can still add the memory manually and even run the ACAclock tool to speed it up. However, "unprotect" is only meant to make changes to the flash, so this should not be used as an "everyday setting". If the "Maprom" setting causes trouble with any software, then it's probably attempting to activate MapRom one more time, which will of course fail. In that case, just remove the jumper (put it on a single pin, so-called "park position"), and it'll come up with all memory, programmed speed but MapROM still available to other software.

    That said, this is most likely not Moff's problem. Since we're talking about a 30-year old computer, it may just be a simple contact problem. As a next step, I recommend to clean the CPU slot on the A1200 side using pure alcohol (or isopropanol, which should be available from any pharmacy) and micro fibre cloth (should be available in any supermarket in the western world). Do not use contact sprays! These often contain additional lubricants for potentiometers, and that's not what you want inside your computer. Isopropanol should be a lot cheaper, and the micro fibre cloth will be soft enough to protect the delicate gold surface, yet strong enough to carry away the fine dust and salt that may have been collected over the decades.

  • Thanks for the info, Jens. With the jumper in its "parked" position, it still does not boot for me - at least with the HSTWB install. I'm running just a bare rev. 2B motherboard at the moment - no keyboard, no disk drive - so I'm thinking there's some weird interaction with something in the startup sequence and my exact config. At any rate, firmly in the "not your problem" basket.

  • Thanks for all the suggestions and tips! It's working now. This is what I did to make it work.

    I first tried to clean the connector with isopropanol, it didn't work.

    Moved the jumper to parking position and unprotected mode, it didn't work.

    Took the Amiga to the Swedish Amiga club(SUGA) and had the capacitors E121C, E122C, E123C and E125C removed. This didn't work either.

    Then we booted into early startup control and checked the "expansion board diagnostics" and could see that the card was inserted and working.

    The we looked in the startup-sequence file and there we commented out the following rows, the first section in the file. Under IF EXIST DEVS:scsi.device:

    C:LoadModule DEVS:scsi.device LIBS:icon.library


    C:LoadModule LIBS:icon.library

    And now the machine boots into workbench and the cards is working!

    Don't know why this work but it does and I hope that this will help others with the same problem.

  • Just to update, turns out my issue was the same as Moff's problem - choking on the LoadModule scsi.device part of startup-sequence. Finally got a keyboard, so was able to flash to the newer version of the ACA1221ec software. This fixed my issue.

  • Just to update, turns out my issue was the same as Moff's problem - choking on the LoadModule scsi.device part of startup-sequence. Finally got a keyboard, so was able to flash to the newer version of the ACA1221ec software. This fixed my issue.

    Good to here that it worked for you to! I decided to install the latest version of AmigaOS, 3.1.4 using these two tutorials:

    Everything worked fine except that the machine didn't boot up without holding the left mouse key during startup. I got the error message "MapRom already active, exiting!". Even when I had installed the latest ACA1221ec software the problem existed. To solve it I had to comment out the following row in my startup-sequence: C:LoadModule ROMUPDATE.

    Just in case you, or anyone else, decides to install AmigaOS 3.1.4 with ACA1221ec and get the same error message.

  • You can also get rid of that message by moving the jumper from "MapROM" to the park position. Note that the jumper activates MapROM in a way that the physical ROMs are copied into the reserved memory space. Once activated, it's quite hard to change the contents of this reserved memory. However, you don't gain much speed by placing the jumper into that position, and we have a number of reports that confirm everything to work fine with the jumper in park position.

  • The last reply was more than 365 days ago, this thread is most likely obsolete. It is recommended to create a new thread instead.