C64R MK2 and Ultimate II (+)

Caution: Non registered users only see threads and messages in the currently selected language, which is determined by their browser Please create an account and log in to see all content by default. This is a limitation of the forum software.
Don't Panic. Please wash hands.
  • I've got a problem with cartridge support and the freeze function on MK2 Reloaded. When I have the Final Cartridge III active (KCS has the same problem) and I press the freeze button I get a "garbled"screen. The menu is working, when pressing the cursor you see the image change. (See screenshot)

    The original Final Cartridge III works correctly (as is the orginal KCS cartridge) with the Freeze function on the MK2 Reloaded.

    The Ultimate II (and + version) with Final Cartridge III with the Freeze function work correctly on a real C64 (pal).

    Is there a (timing?) setting I should set to get the screen to work?

  • Okay tried almost all variations (not all worked) to get it to work for Final Cartridge III -= > Freeze.

    Commodore C64 Reloaded MK2 V20180227

    Best I could get after testing various settings was:

    Ultimate II v3.7:
    CPU Addr valid after PHI2: 120ns

    PHI2 edge recovery: Disabled

    Ultimate II+ v3.7:
    CPU Addr valid after PHI2: 128ns

    PHI2 edge recovery: Disabled

    Screen is barely readable with these settings, but was the best I could get.

    The advice for "PHI2 edge recovery: Enabled" didn't work for me for both of the cartridge versions, I had to disable it to get a "readable" screen.

  • The Phi2 clock is generated by the 6510 CPU. If you have a different type (preferrably the 8500), then this might be worth a try. Further, the CPU generates Phi2 from the Phi0 clock that the VIC provides. If you have a different version of the VIC, you might end up with a timing that the 1541U can deal with. At this point, it seems like you have a very unlucky combination of the two main chips of the computer.

  • Over here i have the same issue with both KCS and Final card III when using the 1541u2+ with the C64 Reloaded mk2.

    The freezer function it self works perfect, but its just that the screen is garbled.

    When i choose the machinecode monitor in the KCS mene, it gives me the machinecode monitor and from then on it simply works again without any artifacts.

    I used different CPU's VIC II's (PAL) and other IC's with different dates 65xx and 85xx sets and combinations. It simply doesnt work with any setting/configuration.

    Cards like the action replay work as intended.

    My best gues is that it has something to with the screenmode (char rom in freezer card memory maybe). But afcource i could be very wrong :D

    On the TC64v2 all the freezer cards work as expected without any corruption. Ans since i personally prefer the TC64.. i totaly forgot about it.

    Needless to say, no issues on my original c64's with both cards.

  • I have reverse-engineered a lot of the old freezer cartridges, and there are lots of cases where you think "why does this work at all??". Some of them heavily rely on component tolerances, which is already a no-go in itself, but after more than 30 years, you just don't have any predictable behaviour any more. This, combined with different production batches and total lack of quality assurance back in the days (ISO 9000 wasn't invented yet!), results in "may or may not work". I'm sorry, but we can't do anything about it.

  • I've tried a few different chips I had. I have 2x 6510 and 3x VIC's from very different different dates). unfortunately the 8500 I had doesn't work.

    I now have a combination for which the screen is better (still artifacts).

    Still had to use these settings for Ultimate II v3.7:

    CPU Addr valid after PHI2: 120ns

    PHI2 edge recovery: Disabled

    I'll leave it at this. It's not that I use it very much, thanks to all the trainers build in the games these days. Can't remember that the games I had in the '80 had them, but it's makes playing a lot easier.

  • hehe, those where the days ;),.Wel, for me its no issue since i preffer the TC64v2 anyway.

    But i think its good to know it doesnt always work.

    Now i'm thinking of it, it can also be the firmware version.. I try to lookup my other u64, this one has an older firmware version (with working tape reading i used to read my original cassetes to sd)