Issues with 1221lc on aca500+

Caution: Non registered users only see threads and messages in the currently selected language, which is determined by their browser Please create an account and log in to see all content by default. This is a limitation of the forum software.
Don't Panic. Please wash hands.
  • Hi there,


    A short while back I had to send in my aca500+ for repair and since I could save on shipping costs I ordered a 1221lc and xsurf500 along with it.

    Now I have an issue with every setup I try (I have 5 original psu's and 7 amiga's :s).


    Every time I enable the freezer and set it to AR3 I can't load whdload games anymore.


    When I try the whole system hangs with a blinking powerled.


    It will reboot fine, but the problem remains, also when I disable AR3 again.


    After a full power down it will work again with freezer off via F1 option.

    I can then reboot into menu, chose F10, set the settings I want and boot with enter.


    After another powerdown though, I will have to use F1 again, or the problem persists. After disconnecting the psu and plugging it in again I can boot straight away via the F10 option again.


    I've tried setups from my a500 plus with 2 mb to a complete vanilla a500, and tried all with different psu's, no combo works.

    All updates have been performer twice in following


    order :

    Menu

    Installer

    Network

    Hrtmon


    On the software side I've tried it on 6 different games, latest whdload and slaves. All works fine without AR3 enabled.


    I've tried it many times now followinf the following steps :


    - reinstall OS via acamenu

    - booting with F1

    - softreset with mouse down

    -Aca menu option F10

    - Enable AR freezer

    - Boot with enter


    The other settings in the F10 menu don't seem to be of any influence, it will work.

    No settings via F10 will work until the psu has been disconnected after the problem occurs.


    At first when I noticed the problem, it seemed as if an OS reinstall was necessary.

    This however will most likely have been because of bogged cf slots after trying the 40mhz overclock.


    I know it is not supported, but since I have 5 original psu's I thought I had a good chance..


    Alas, also here no setup will work and it's almost always instant failure.


    With aux disabled it might 'work' ever so briefly, but it will hang within minutes.


    The reason I am mentioning it is because it is absolutely instant and once done, the wrong settings seem to persist.


    When I hold down the left mouse button during startup, after the system failed, I get a red screen and the safe settings are applied


    This doesn't happen automatically though.


    Also it seems to bog the cf slots.


    When the aux was on, it couldn't be used again until correct setting were restored and the system had a complete power down and psu switch (regardless which one, on repeating the issue I'd switch back and forth between the same ).


    Yesterday, when also trying to recreate my 16gb PNY cf card seems busted. It will only show 32mb, also under WinXP disk management and can't be formatted anymore on either pc or amiga.

    So to me it appears there might be some unwanted interaction with the cf slots.



    Hope you can help me further with this,

    Best regards,


    Paul

  • Fixing this requires not only a change in the ACA500plus menu system software, but also in WHDload.


    Remember that the freezer (especially AR3) is a 68000-only device - only recently we started modifying the AR3 code to also work with 68020 and higher CPUs, and for the possibilities we have with the current WHDload, it is working quite well - though not perfect, as you observed.


    That said, the author of WHDload has agreed to adding the required support, so we have the chance to fix it in the future. No promises on a timeline though; this is a "bonus feature" and we depend on WHDload to add support for freezers for CPUs other than the 68000 (WHDload takes over the exception vectors of the higher CPUs, and so far, it only supports HRTmon as freezer).